Задать вопрос
12 марта, 11:52

Начав тренировки, лыжник в первый день пробегал 10 км.

В каждый следующий день он увеличивал длину пробега на 10% от предыдущего дня. Определить, в какой день он пробежит 20 км.

Составить программу в паскале.

(Оператор Цикл. Цикл с предусловием.)

+4
Ответы (1)
  1. 12 марта, 14:14
    0
    Вариант номер 1:

    program c1ba;

    var a:byte;

    p:real;

    begin

    p:=10;

    a:=1;

    repeat begin

    p:=p + (p/10) ;

    a:=a+1;

    end;

    until p>=20;

    writeln ('a=', a) ;

    end.

    Вариант номер 2:

    program c1ba;

    var a:byte;

    p:real;

    begin

    p:=10;

    a:=1;

    while p<=20 do begin

    p:=p + (p/10) ;

    a:=a+1;

    end;

    writeln ('a=', a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Начав тренировки, лыжник в первый день пробегал 10 км. В каждый следующий день он увеличивал длину пробега на 10% от предыдущего дня. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы