Задать вопрос
29 сентября, 17:20

Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье становится разностью третьего и второго, если оно больше второго.

+2
Ответы (1)
  1. 29 сентября, 19:11
    0
    Var

    number1, number2, number3 : real;

    begin

    write ('Первое число: ') ;

    readln (number1) ;

    write ('Второе число: ') ;

    readln (number2) ;

    write ('Третье число: ') ;

    readln (number3) ;

    if (number1 > number3) then number1 : = number1 / 3;

    if (number3 > number2) then number3 : = number3 - number2;

    writeln ('Вывод') ;

    writeln ('Первое число: ', number1) ;

    writeln ('Второе число: ', number2) ;

    writeln ('Третье число: ', number3) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы