Задать вопрос
29 апреля, 11:17

10 класс Напишите программу в паскале, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 undefined признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300.

Списанные программы не засчитываю, я тоже умею пользоваться поисковиками

+3
Ответы (1)
  1. 29 апреля, 15:16
    0
    Program n1;

    const n=100;

    var a: array [1 ... n] of integer;

    i, sum, k: integer;

    begin

    for i:=1 to n do

    begin

    write ('введите ', i,' элемент: ') ;

    readln (a[i]) ;

    if (a[i]=0) or (a[i]>300) then break;

    if (a[i]99) then

    begin

    k:=k+1;

    sum:=sum+a[i];

    end;

    end;

    if k0 then writeln ('ср. ариф: ', sum/k)

    else writeln ('no') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «10 класс Напишите программу в паскале, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы