Задать вопрос
23 декабря, 15:02

Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов.

+3
Ответы (1)
  1. 23 декабря, 18:01
    0
    program jfe3;

    const n=10; {Это будет кол-во элементов массива}

    var a:array [1 ... n] of integer; i, s:integer;

    begin

    for i:=1 to n do begin

    a[i]:=random (100) ; {элемент выбирается случайно от 0 до 100}

    s:=s+a[i]; {Когда эл. присвоился, его значение плюсуется к общ сумме}

    end;

    for i:=1 to n do

    writeln (a[i],' ') ; {показать сам массив}

    writeln (s) ; {показать сумму}

    readln; {чтобы окно сразу не закрывалось}

    end.

    Если есть вопросы по программе, пиши в личку. Если надо что-то еще - тоже =)

    Удачи)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы