Задать вопрос
6 марта, 06:16

Написать программу Паскаль - Вывести на экран элементы, которые больше значения элемента, номер которого введен с клавиатуры

+1
Ответы (1)
  1. 6 марта, 09:35
    0
    Var

    arr : array [1 ... 30] of integer;

    i, number : integer;

    begin

    //Заполнение массива случайными числами

    for i : = 1 to 30 do

    arr[i] : = Random (10000) - 5000;

    //---

    //Считывание номера элемента и проверка на соответствие условию

    write ('Введите число: ') ;

    readln (number) ;

    if not (number in [1 ... 30]) then

    begin

    write ('Ошибка. Номер элемента выходит за границу массива') ;

    Exit;

    end;

    //---

    //Вывод массива с учётом условия

    for i : = 1 to 30 do

    if arr[i] > arr[number] then

    write (arr[i], ' ') ;

    //---

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу Паскаль - Вывести на экран элементы, которые больше значения элемента, номер которого введен с клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы