Задать вопрос
7 октября, 06:13

1) Найти сумму нечетных чисел на интервале [-30; 40].

2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9.

3) Найти произведение чисел кратных 11 на интервале [-10; 20].

4) Последовательно вводятся N чисел. Найти их произведение.

+1
Ответы (1)
  1. 7 октября, 06:41
    0
    1.)

    var s, i: integer;

    begin

    for i:=-30 to 40 do

    if i mod 2 0 then s:=s+i;

    writeln (s) ;

    end.

    2.)

    var s, i: integer;

    begin

    for i:=-50 to 120 do

    if i mod 9 = 0 then s:=s+1;

    writeln (s) ;

    end.

    3.)

    var p, i: integer;

    begin

    for i:=-10 to 20 do

    begin

    if i=1 then p:=1;

    if i mod 11 = 0 then p:=p*i;

    end;

    writeln (p) ;

    end.

    4.)

    var n, d, i, p: integer;

    begin

    p:=1;

    write ('Введите n>> ') ;

    readln (n) ;

    for i:=1 to n do

    begin

    write ('Введите ', i, '-ое число>> ') ;

    readln (d) ;

    p:=p*d;

    end;

    writeln (p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Последовательно вводятся целые положительные числа, пока не будет введено отрицательное число. Определить разность между суммой чисел кратных семи и количеством четных чисел.
Ответы (1)