Задать вопрос
5 февраля, 05:31

Даны два натуральных числа. Выяснить в каком из них сумма цифр

больше. Написать программу в паскале абс, использую функцию.

+4
Ответы (1)
  1. 5 февраля, 07:36
    0
    Function summ (a : integer) : integer;

    var

    s : integer;

    begin

    s : = 0;

    while (a > 0) do

    begin

    s : = s + a mod 10;

    a : = a div 10;

    end;

    summ : = s;

    end;

    var

    a, b : integer;

    begin

    read (a, b) ;

    a : = summ (a) ;

    b : = summ (b) ;

    if a > b then write ('in 1') else if b > a then write ('in 2') else write ('eq') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны два натуральных числа. Выяснить в каком из них сумма цифр больше. Написать программу в паскале абс, использую функцию. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы