Задать вопрос
9 декабря, 22:45

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. получите новый масив, каждый элемент которого равен среднему арифметическому соответствующего элемента исходного массива и введенного с клавиатуры числа А. В полученном массиве найдите максимальный элемент среди элементов с нечетными номерами. Выведите на экран исходные и полученные результаты.

+4
Ответы (1)
  1. 9 декабря, 23:28
    0
    Uses crt;

    const n=15;

    var a:array[1 ... n] of real;

    max:real;

    i, c:integer;

    begin

    randomize;

    readln (c) ;

    max:=-50;

    for i:=1 to n do

    begin

    a[i]:=random (100) - 50;

    write (a[i]:4) ;

    end;

    writeln;

    writeln;

    for i:=1 to n do

    begin

    a[i]: = (c+a[i]) / 2;

    write (a[i]:4) ;

    end;

    writeln;

    writeln;

    for i:=1 to n do

    begin

    if (i mod 20) then

    begin

    if a[i]>max then max:=a[i];

    end;

    end;

    write (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. получите новый масив, каждый элемент которого равен ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы