Задать вопрос
26 июня, 16:18

Составить программу в паскале используя функции или процедуры, которая будет вычеслять площадь треугольника по трем сторонам. в программе выполнить проверку существования треугольника

+2
Ответы (1)
  1. 26 июня, 18:49
    0
    Function S (a, b, c:real) : real;

    Var

    p:real;

    Begin

    p: = (a+b+c) / 2;

    result:=Sqrt (p * (p-a) * (p-b) * (p-c))

    End;

    Var

    a, b, c:real;

    Begin

    Write ('a = ') ; ReadLn (a) ;

    Write ('b = ') ; ReadLn (b) ;

    Write ('c = ') ; ReadLn (c) ;

    if (a
    End.

    Пример:

    a = 3

    b = 4

    c = 5

    S = 6
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в паскале используя функции или процедуры, которая будет вычеслять площадь треугольника по трем сторонам. в программе ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы