Задать вопрос
8 августа, 06:41

Паскаль

Составить программу, которая выводит меню и при нажатии вводе цифры вычисляет соответствующее

выражение:

1 - y = (a+b) ^2

2 - y = a^2-b^2

3 - y = 1 / (a+b)

+5
Ответы (1)
  1. 8 августа, 09:20
    0
    Var i, y, a, b: single;

    begin

    writeln ('Выберите действие: 1) y = (a+b) ^2; 2) y=a^2-b^2; 3) y=1 / (a+b) ') ;

    read (i) ;

    if i=1 then begin

    writeln ('Введите a и b') ;

    read (a, b) ;

    write ('y=', (a+b) * (a+b)) ;

    end

    else begin

    if i=2 then begin

    writeln ('Введите a и b') ;

    read (a, b) ;

    write ('y=', (a*a) - (b*b)) ;

    end

    else begin

    if i=3 then begin

    writeln ('Введите a и b') ;

    read (a, b) ;

    write ('y=',1 / (a+b)) ;

    end;

    end;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль Составить программу, которая выводит меню и при нажатии вводе цифры вычисляет соответствующее выражение: 1 - y = (a+b) ^2 2 - y = ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы