Задать вопрос
12 октября, 09:26

Помогите решить задачу о Паскалю

Дано четыре числа. Необходимо найти произведение тех чисел, которые находятся в диапазоне от 3 до 9 включительно. Формат входных данных С клавиатуры вводятся 4 целых числа, по модулю не превосходящих 20. Формат выходных данных Необходимо вывести единственное число - искомое произведение. Если чисел, удовлетворяющих условию, нет, выведите - 1.

+2
Ответы (1)
  1. 12 октября, 12:38
    0
    Var n, k, i: integer;

    begin k : = 1; for i : = 1 to 4 do begin read (n) ; if (n > = 3) and (n < = 9) then k : = k * n; end; if k = 1 then writeln (-1) else writeln (k) ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить задачу о Паскалю Дано четыре числа. Необходимо найти произведение тех чисел, которые находятся в диапазоне от 3 до 9 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы