Задать вопрос
5 июля, 15:24

Напишите программу в результате которой первое введеное число уменьшается в 2 раза, если оно больше третьего, а третье разностью третьего и второго, если оно больше второго! На языке Паскаль

+2
Ответы (2)
  1. 5 июля, 16:31
    0
    Var

    x, y, z:real;

    begin

    write ('Введите 1 число: ') ;

    readln (x) ;

    write ('Введите 2 число: ') ;

    readln (y) ;

    write ('Введите 3 число: ') ;

    readln (z) ;

    if x>z then x:=x/2;

    if z>y then z:=z-y;

    writeln ('1 число: ', x) ;

    writeln ('2 число: ', y) ;

    writeln ('3 число: ', z) ;

    readln;

    end.
  2. 5 июля, 17:03
    0
    Var

    a, b, c:real;

    begin

    Readln (a, b, c) ;

    if a > c then a: = a/2;

    if c > b then c: = c-b;

    Writeln (a, ' ', b, ' ', c) ;

    end.

    Пример:

    4 2 3

    2 2 1
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в результате которой первое введеное число уменьшается в 2 раза, если оно больше третьего, а третье разностью третьего и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы