Задать вопрос
1 февраля, 10:16

Помогите написать программу в паскале. Задание: На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала координат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

+1
Ответы (1)
  1. 1 февраля, 13:44
    0
    program prog;

    var x1, x2, y1, y2, i, b:integer;

    begin;

    writeln ('Введите 4 точки: x1, y1; x2, y2') ;

    readln (x1, y1, x2, y2) ;

    i:=abs (x1+y1) ;

    b:=abs (x2+y2) ;

    if i=b then writeln ('Координаты находятся на одной точке') else begin

    if i>b then writeln ('Первая координата дальше') else writeln ('Вторая координата дальше') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в паскале. Задание: На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы