Задать вопрос
18 февраля, 14:29

Нужно написать программу. Найдите сумму цифр не кратных 3 и произведение цифр больших 5 в записи числа.

+5
Ответы (1)
  1. 18 февраля, 17:09
    0
    var

    a, b, s, p : integer;

    begin

    readln (a) ;

    s : = 0;

    p : = 1;

    while a > 0 do

    begin

    b : = a mod 10;

    a : = a div 10;

    if b mod 3 0 then

    s : = s + b;

    if b > 5 then

    p : = p * b;

    end;

    if p = 1 then

    p : = 0;

    writeln (s) ;

    writeln (p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно написать программу. Найдите сумму цифр не кратных 3 и произведение цифр больших 5 в записи числа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы