Задать вопрос
22 апреля, 21:13

Массив из пяти элементов заполняется натуральными числами. Составить программу, которая определяет сумму элементов массива, кратных трем и заканчивающихся на 7 (программа Pascal)

+1
Ответы (1)
  1. 22 апреля, 21:35
    0
    Var a:array[1 ... 5] of integer;

    i, s:integer;

    begin

    writeln ('Введите 5 чисел:') ;

    for i:=1 to 5 do

    begin

    read (a[i]) ;

    if (a[i] mod 3 = 0) and (a[i] mod 10 = 7) then s:=s+a[i];

    end;

    writeln ('s = ', s) ;

    end.

    Пример:

    Введите 5 чисел:

    125 273 117 471 207

    s = 324
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Массив из пяти элементов заполняется натуральными числами. Составить программу, которая определяет сумму элементов массива, кратных трем и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы