Задать вопрос
18 января, 08:59

Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные:

Входной поток содержит два целых числа N и K (1 < = N < = 10^100, 1 < = K < = 10^9) записанные в двух отдельных строках.

Выходные данные:

В выходной поток выведите остаток от деления N на K.

Пример входного файла (input. txt) : 239 16 Пример выходного файла (output. txt) : 15

+1
Ответы (1)
  1. 18 января, 11:06
    0
    Program Task;

    Var t: Text;

    N, K, M: LongInt;

    Begin

    Assign (t, 'd:/input. txt') ;

    Reset (t) ;

    While Not EOF (t) Do

    Begin

    Read (t, N) ;

    Read (t, K) ;

    End;

    If (N Exp (100 * Ln (10))) Or (K Exp (9 * Ln (10))) Then

    WriteLn ('Input error!')

    Else

    Begin

    M : = N Mod K;

    Assign (t, 'd:/output. txt') ;

    Rewrite (t) ;

    Write (t, M) ;

    Close (t) ;

    Write ('Done.') ;

    End;

    ReadLn;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два целых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы