Задать вопрос
20 мая, 15:31

Задача №1 Составить программу проверяющую является ли слово "перевертышем"

Задача №2 Подсчитать каких букв в предложении больше "а" или "е"

все в паскале

+3
Ответы (1)
  1. 20 мая, 15:55
    0
    var

    S:string;

    i:integer;

    begin

    write ('S = ') ;

    readln (S) ;

    for i : = 1 to Length (S) do

    if S[i] S[Length (S) - i + 1] then

    begin

    writeln ('No') ;

    readln;

    Exit;

    end;

    writeln ('Yes') ;

    readln;

    end.

    //вторая программа

    var

    S:string;

    i, countA, countE:integer;

    begin

    CountA : = 0;

    CountE : = 0;

    write ('S = ') ;

    readln (S) ;

    for i : = 1 to Length (S) do

    if S[i] = 'a' then

    inc (countA)

    else

    if S[i] = 'e' then

    inc (countE) ;

    if countA > countE then

    writeln ('a > e')

    else

    if countA < countE then

    writeln ('a < e')

    else

    writeln ('a = e') ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача №1 Составить программу проверяющую является ли слово "перевертышем" Задача №2 Подсчитать каких букв в предложении больше "а" или "е" ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы