Задать вопрос
17 февраля, 18:10

Паскаль. Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.

Входящие данные: R (радиус) ;

Выходящие данные: S (площадь), L (длина окружности)

+2
Ответы (1)
  1. 17 февраля, 19:29
    0
    Program primer; const Pi=3.14;

    procedure SandL (R: integer; var S, L: real) ;

    begin

    S:=Pi*Power (R, 2) ; L:=2*R*Pi; end;

    var R: integer;

    S, L: real;

    Begin

    readln (R) ;

    SandL (r, s, l) ;

    writeln (Trunc (s),' ', Trunc (l)) ;

    end.

    ABC Pascal
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль. Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
Python Middle: 1. Напиcать функцию, которая возвращает частное двух чисел, полученных в качестве аргументов. 2. Напиcать функцию, которая возвращает минимальное из двух чисел, полученных в качестве аргументов. 3.
Ответы (1)
Установите взаимно-однозначное соответствие между функциями и их действием: 1) Возвращает значение, следующее за х а) chr (x) 2) Возвращает значение, предшествующее х б) pred (x) 3) Возвращает символ с кодом х, где х - целое число от 0 до 255 в)
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)