Задать вопрос
4 мая, 01:08

Напишите программу, которая в последоваnельности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Ко личе ство чисел не пре вы ша ет 1000. Введённые числа не пре вы ша ют 30 000. Пграмма должна вывести одно число - максимальное число, кратное 5.

+5
Ответы (1)
  1. 4 мая, 01:48
    0
    Program kratnoe;

    var N, i, a, max: integer;

    begin

    writeln ('Введите количество чисел:') ; Readln (N) ;

    max:=0;

    For i:=1 to N do

    begin

    write ('Введите число:') ; readln (a) ;

    if a mod 5 = 0 then

    if a>max then max:=a;

    end;

    writeln ('ответ:', max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая в последоваnельности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы