Задать вопрос
4 августа, 01:31

Билет на одну поездку в метро стоит 15 рублей, билет на 5 поездок стоит 70 рублей, билет на 10 поездок стоит 125 рублей, билет на 20 поездок стоит 230 рублей, билет на 60 поездок стоит 440 рублей. Пассажир планирует совершить n поездок. Определите, сколько билетов каждого вида он должен приобрести, чтобы суммарное количество оплаченных поездок было не меньше n, а общая стоимость приобретенных билетов - минимальна.

Формат входных данных

Дано одно число n - количество поездок.

Формат выходных данных

Выведите пять целых чисел, равные необходимому количеству билетов на 1, на 5, на 10, на 20, на 60 поездок. Если для какого-то данного n существует несколько способов приобретения билетов одинаковой стоимости, необходимо вывести ту комбинацию билетов, которая дает большее число поездок.

+4
Ответы (1)
  1. 4 августа, 03:33
    -1
    чем больше поездок тем дешевле билет, начинаем с максимального

    var

    n60, n20, n10, n5, n1, n: integer;

    begin

    readln (n) ;

    n60 : = n div 60;

    n : = n - n60 * 60;

    n20 : = n div 20;

    n : = n - n20 * 20;

    n10 : = n div 10;

    n : = n - n10 * 10;

    n5 : = n div 5;

    n1 : = n - n5 * 5;

    writeln (n1) ;

    writeln (n5) ;

    writeln (n10) ;

    writeln (n20) ;

    writeln (n60) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Билет на одну поездку в метро стоит 15 рублей, билет на 5 поездок стоит 70 рублей, билет на 10 поездок стоит 125 рублей, билет на 20 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы