Задать вопрос
20 июля, 22:15

Составьте программу которая выводит на печать все двузначные числа, которые делятся на сумму своих цифр

+4
Ответы (1)
  1. 21 июля, 00:16
    0
    Var i1, i2:integer;

    begin

    for i1:=1 to 9 do

    for i2:=0 to 9 do

    if (i1*10+i2) mod (i1+i2) = 0 then

    write (i1*10+i2,' ') ;

    writeln;

    end.

    Результат:

    10 12 18 20 21 24 27 30 36 40 42 45 48 50 54 60 63 70 72 80 81 84 90
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу которая выводит на печать все двузначные числа, которые делятся на сумму своих цифр ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы