Задать вопрос
1 января, 15:13

Задача 1.

Дан массив из 30 элементов, заполненный целыми случайными числами из диапазона от - 15 до + 50. Вычислить сумму всех элементов массива, определить количество элементов массива кратных 3. Исходный массив и результат подсчета (количество и сумма) вывести на экран.

Задача 2.

Упорядочить массив из 20 целых чисел по убыванию. Исходный и упорядоченный массив вывести на экран.

Задача 3.

Составьте программу, которая по фамилии, имени и отчеству человека выводит на экран фамилию и инициалы человека.

например, Иванов Петр Степанович должно получиться на экране Иванов П. С.

+2
Ответы (1)
  1. 1 января, 18:18
    0
    1) var

    a: array [1 ... 30] of integer;

    i, s, k: integer;

    begin

    for i : = 1 to 30 do//заполнение рандомными числами (от - 15 до 50, включая и - 15 и 50) массив

    a[i] : = random (-15, 50) ;

    for i : = 1 to 30 do//сумма элементов и подсчет кратных 3

    begin

    s : = s + a[i]; //сумма элементов

    if a[i] mod 3 = 0 then//подсчет кол во кратных 3

    k : = k + 1;

    end;

    writeln ('Исходный массив') ;

    for i : = 1 to 30 do

    writeln ('A[', i, '] = ', a[i]) ;

    writeln ('Сумма элементов массива: ', s) ;

    writeln ('Кратных 3: ', k) ;

    end.

    извини помог бы дальше но дела но вот подсказки:

    2) метод пузырька посмотри

    3) там через функцию поиска и удаления

    если над у меня есть группа в вк называется просто программки если интересно можешь глянуть
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача 1. Дан массив из 30 элементов, заполненный целыми случайными числами из диапазона от - 15 до + 50. Вычислить сумму всех элементов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы