Задать вопрос
2 сентября, 16:59

Помогите с программой в паскале с помощью процедуры

Процедура выводит N целых случайных чисел с интервала a, b

+1
Ответы (1)
  1. 2 сентября, 18:50
    0
    Procedure RND (a, b, n:integer) ;

    var

    i:integer;

    begin

    Randomize;

    for i:=1 to n do Write (Random (b-a+1) + a,' ')

    end;

    var

    a, b, n:integer;

    begin

    Write ('Задайте интервал для генерирования чисел ') ;

    Read (a, b) ;

    Write ('Укажите количество случайных чисел: ') ; Read (n) ;

    RND (a, b, n)

    end.

    Тестовое решение:

    Задайте интервал для генерирования чисел - 5 10

    Укажите количество случайных чисел: 30

    -4 1 4 - 1 3 - 4 9 1 5 - 1 - 1 9 1 - 2 - 5 - 2 1 - 2 2 - 3 2 - 4 7 10 - 3 3 10 5 6 - 1
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите с программой в паскале с помощью процедуры Процедура выводит N целых случайных чисел с интервала a, b ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы