Задать вопрос
2 марта, 08:21

надо составить программу в паскале, в которой надо найти процент от заданного числа

+1
Ответы (1)
  1. 2 марта, 09:02
    0
    Var

    q: Single; / / Результат. Если число будет больше, то указать Double

    i: Single; / / Число из которого необходимо получить результат. Если число будет больше, то указать Double

    p: Single; / / Процент. Если процент будет всегда целым числом, то указать Byte

    begin

    writeln ('Введите число = > ') ;

    read (i) ;

    writeln ('Введите процент, который хотите расcчитать из введенного числа = > ') ;

    read (p) ;

    while p < 0 do

    begin

    writeln ('Процент не может быть меньше нуля, введите новое значение = > ') ;

    read (p) ;

    end;

    q: = (i / 100) * p;

    writeln ('Ваш результат из числа = > ', i, ', ', p, '% = ', q) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «надо составить программу в паскале, в которой надо найти процент от заданного числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы