Задать вопрос
1 января, 21:49

Помогите с Паскалем ABS.

1 дано пятизначное число. определить сумму второй и пятой цифры.

2 дано пятизначное число. Определить сумму второй и четвёртой цифрой.

3 написать программу в которой подсчитывается количество чётных чисел среди трёх, введёных с клавиатуры

+4
Ответы (2)
  1. 1 января, 22:10
    0
    № 1-2

    var x, t, f, l, sum, sum2: integer;

    begin

    write ('Введите x: ') ;

    readln (x) ;

    if (x 99999) then

    writeln ('Ошибка. Число не пятизначное!')

    else

    begin

    l : = x mod 10;

    t : = (x div 1000 mod 10) ;

    sum : = l + t;

    f : = (x div 10 mod 10) ;

    sum2 : = t + f;

    writeln ('Сумма второй и последней цифры: ', sum) ;

    writeln ('Сумма второй и четвертой цифры: ', sum2) ;

    end;

    end.

    №3

    var a, b, c, rez: integer;

    begin

    write ('Введите первое число: ') ;

    readln (a) ;

    write ('Введите второе число: ') ;

    readln (b) ;

    write ('Введите третье число: ') ;

    readln (c) ;

    rez : = 0;

    if a mod 2 = 0 then inc (rez) ;

    if b mod 2 = 0 then inc (rez) ;

    if c mod 2 = 0 then inc (rez) ;

    writeln ('Количество четных чисел: ', rez) ;

    end.
  2. 1 января, 23:26
    0
    №2.

    var a, b: integer;

    beginreadln (a) ;

    b:=a;

    a: = (a div 10) mod 10;

    b: = (b div 1000) mod 10;

    writeln (b+a) ;

    end.

    №1.

    var a, b: integer;

    beginreadln (a) ;

    b:=a;

    a: = a mod 10;

    b: = (b div 1000) mod 10;

    writeln (b+a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите с Паскалем ABS. 1 дано пятизначное число. определить сумму второй и пятой цифры. 2 дано пятизначное число. Определить сумму второй ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Укаждите условия, истинные при х=2, у=-7, z=9. а) abs (x) + abs (y) = z б) z-y=abs (x) в) abs (x+y) = z
Ответы (1)
Укажите условия, истинные при x=2, y=-7, z=9. a) abs (x) + abs (y) = z b) z-y=abs (x) в) abs (x+y) = z
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Для числа подсчитывается сумма его цифр. Если результат превышает 9, то для результата снова подсчитывается сумма цифр и так далее, пока результат не станет меньше 10. Выполните расчеты для введенного с клавиатуры не более чем 50-значного числа.
Нет ответа
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)