Задать вопрос
7 августа, 23:53

Задача 2. Замечательная игра

Вот Уже N дней подряд Руслан играет в замечательную игру. Каждый день у него получаться сыграть ровно 7 раз. В конце каждой игры он набирает от 0 до 10 очков. Игра считается результативной если в ней было набрано более 3 очков

Помогите подсчитать Руслану сумму очков всех результативных игр для каждого дня.

Формат ввода:

N (1<=N<=100) - Количество дней

1[1.1] a[1.2] a[1.3] a[1.4] a[1.5] a[1.6] a[1.7]

a[2,1] a[2,2] a[2,3] a[2,4] a[2,5] a[2,6] a[2,7]

...

a [N, 1] a [N, 2] a [N, 3] a [N, 4] a [N, 5] a [N, 6] a [N, 7]

(0<=1[I, i] <=10) - очки набранные в I-ый день в j-ой игре.

Формат вывода

ans[1]

ans[2]

...

ans[N] - Сумму очков всех результативных игр для каждого дня.

Пример ввода: Пример вывода:

3 15

0 1 2 3 4 5 6 49

7 7 7 7 7 7 7 10

0 1 2 3 3 2 10

+4
Ответы (1)
  1. 8 августа, 00:50
    0
    Const m=7;

    var

    a:array of array of integer;

    ans:array of integer;

    n, i, j:integer;

    begin

    readln (n) ;

    SetLength (a, n) ;

    for i:=0 to n-1 do SetLength (a[i], m) ;

    SetLength (ans, n) ;

    for i:=0 to n-1 do

    begin

    for j:=0 to m-1 do read (a[i, j]) ;

    readln;

    end;

    for i:=0 to n-1 do

    for j:=0 to m-1 do

    if a[i, j]>3 then ans[i]:=ans[i]+a[i, j];

    for i:=0 to n-1 do writeln (ans[i]:4) ;

    writeln;

    end.

    Пример:

    3

    0 1 2 3 4 5 6

    7 7 7 7 7 7 7

    0 1 2 3 3 2 10

    15

    49

    10
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача 2. Замечательная игра Вот Уже N дней подряд Руслан играет в замечательную игру. Каждый день у него получаться сыграть ровно 7 раз. В ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы