Задать вопрос
25 января, 23:49

Помогите написать программу на паскале абс

цикл с постусловием

Дано целое число N (> 1). Вывести наименьшее из целых чисел K, для которых сумма

1 + 2 + ... + K будет больше или равна N, и саму эту сумму.

+4
Ответы (1)
  1. 26 января, 03:19
    0
    Var n, k, summ:integer;

    begin

    write ('Введи число N: ') ;

    readln (n) ;

    repeat begin

    k:=k+1;

    summ:=summ+k;

    end;

    until summ>=n;

    writeln ('K=', k,', 1 + ... + ', k,'=', summ,', ', summ,'>=', N) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на паскале абс цикл с постусловием Дано целое число N (> 1). Вывести наименьшее из целых чисел K, для которых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы