Задать вопрос
17 апреля, 09:39

Составить программу для паскаля. 1) Определить количество трехзначных чисел сума цифр которых равна числу N. 2) Дано натуральное число N. Составить программу меняющихся местами первую и последнюю цифру.

+2
Ответы (1)
  1. 17 апреля, 12:00
    0
    1)

    var s: string;

    i, n, c: integer;

    begin

    read (n) ;

    for i : = 100 to 999 do

    begin

    s:=inttostr (i) ;

    c: = (strtoint (s[1]) + strtoint (s[2]) + strtoint (s[3])) ;

    if (n=c) then writeln (s) ;

    end;

    end.

    2)

    var s: string;

    begin

    read (s) ;

    swap (s[1], s[s. Length]) ;

    write (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для паскаля. 1) Определить количество трехзначных чисел сума цифр которых равна числу N. 2) Дано натуральное число N. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы