Задать вопрос
23 июля, 09:55

Написать программу (в Паскале) поиска элемента массива, равного 50

+1
Ответы (1)
  1. 23 июля, 10:02
    0
    Const n=20; p=50;

    var a:array[1 ... n+1] of integer;

    i:integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    a[i]:=random (100) ;

    write (a[i]:4) ;

    end;

    writeln;

    a[n+1]:=p;

    i:=1;

    while a[i]p do i:=i+1;

    if i
    else writeln ('Значения ', p,' в массиве нет') ;

    end.

    Пример:

    76 27 15 97 12 14 72 50 51 8 40 47 38 28 30 47 31 4 94 3

    Значение = 50 - это 8 элемент массива
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу (в Паскале) поиска элемента массива, равного 50 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы