Задать вопрос
19 ноября, 02:12

Напишите программу. и блок-схему.

Вводится массив из 15 элементов, нужно определить сколько эл. массива будут между его макс и миним. элементом.

+2
Ответы (1)
  1. 19 ноября, 05:23
    0
    Uses crt;

    const n = 15;

    var i, imin, imax, m, min, max, j: integer;

    a: array[1 ... n]of integer;

    begin

    Writeln ('Введите числа в массив') ;

    for i : = 1 to n do

    readln (a[i]) ;

    for i : = 1 to n do

    write (a[i], ' ') ;

    min : = a[1];

    max : = a[1];

    imin : = 1;

    imax : = 1;

    for j : = 1 to n do

    begin

    if (a[j] > max) then

    begin

    max : = a[j];

    imax : = j;

    end;

    if (a[j] < min) then

    begin

    min : = a[j];

    imin : = j;

    end;

    end;

    writeln () ;

    writeln ('индекс минимального элемента ', imin, ' индекс максимального элемента ', imax) ;

    m : = abs (imin - imax) ;

    Writeln () ;

    Writeln ('Кол-во элементов между макс. и мин. элементами ', m - 1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу. и блок-схему. Вводится массив из 15 элементов, нужно определить сколько эл. массива будут между его макс и миним. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы