Задать вопрос
6 октября, 13:58

Составить программу для нахождения наибольшего общего делителя четырёх натуральных чисел используя процедуру

+4
Ответы (1)
  1. 6 октября, 17:43
    0
    Program z1;

    var a, b, c, d:integer;

    procedure nod (x, y:integer; var nod2:integer) ;

    begin

    while xy do begin

    if x>y then begin

    x:=x-y

    end

    else begin

    y:=y-x

    end

    end;

    nod2:=xend;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    write ('c=') ; readln (c) ;

    write ('d=') ; readln (d) ;

    nod (a, b, b) ;

    nod (b, c, c) ;

    nod (c, d, d) ;

    writeln ('nod=', d) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для нахождения наибольшего общего делителя четырёх натуральных чисел используя процедуру ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы