Задать вопрос
7 декабря, 03:08

Составьте программу, вычисляющую для двух дробей a/b и c/d (a, b, c, d - натуральные числа) :

деление

умножение

сложение.

Результат представить в виде простых несократимых дробей

В виде функции.

Pascal

+1
Ответы (1)
  1. 7 декабря, 07:01
    0
    Как-то так)

    var a, b, c, d, e, f:integer;

    function nod (m, n:integer) : integer;

    begin

    while mn do

    if m>n then m:=m-n

    else n:=n-m;

    nod:=m

    end;

    begin

    write ('введите числитель1, знаменатель1, числитель2, знаменатель2') ;

    readln (a, b, c, d) ;

    e:=a*d+b*c;

    f:=b*d;

    if f=0 then write ('на 0 делить нельзя')

    else

    if e=0 then writeln ('сложение = ', e)

    else begin

    e:=e div nod (abs (e), f) ;

    f:=f div nod (abs (e), f) ;

    writeln ('сложение = ', e,'/', f) ;

    end;

    e:=a*c;

    f:=b*d;

    if f=0 then write ('на 0 делить нельзя')

    else

    if e=0 then writeln ('умножение = ', e)

    else begin

    e:=e div nod (abs (e), f) ;

    f:=f div nod (abs (e), f) ;

    writeln ('умножение = ', e,'/', f) ;

    end;

    e:=a*d;

    f:=b*c;

    if f=0 then write ('на 0 делить нельзя')

    else

    if e=0 then writeln ('деление = ', e)

    else begin e:=e div nod (abs (e), f) ;

    f:=f div nod (abs (e), f) ;

    writeln ('деление = ', e,'/', f) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, вычисляющую для двух дробей a/b и c/d (a, b, c, d - натуральные числа) : деление умножение сложение. Результат ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы