Задать вопрос
27 сентября, 09:46

G. Жилищная проблема муравьев

Население инсектополиса составляет N муравьев. Известно, что в одном муравейнике помещается 1000 муравьев, при том один муравейник на 1000 особей уже построен. Определите, сколько еще нужно построить муравейников, чтобы ни в одном из них не было перенаселения.

Формат входных данных

Целое положительное число муравьев N (1 < N < 109)

Формат выходных данных

Целое число - необходимое количество дополнительных муравейников

Примеры:

входные данные выходные данные

2000

1

2001

2

+1
Ответы (1)
  1. 27 сентября, 11:21
    -1
    Var n, k:integer;

    begin

    readln (n) ;

    k: = (n-1) div 1000;

    writeln (k) ;

    end.

    Пример:

    2001

    2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «G. Жилищная проблема муравьев Население инсектополиса составляет N муравьев. Известно, что в одном муравейнике помещается 1000 муравьев, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы