Задать вопрос
20 января, 13:56

1 Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см, а каждый пасмурный день опускается вниз на 1 см, В начале наблюдения улитка находится в A см от земли на B-метровом дереве. Имеется 30-элементный массив, содержащий сведения о том, был ли соответствующий день наблюдения пасмурным или солнечным. Написать программу, определяющую местоположение улитки к концу 30-го дня наблюдения.

2. У вас есть доллары. Вы хотите обменять их на рубли. Есть информация о купли-продажи в банках города. В городе N банков. Составить программу, определяющую, какой банк выбрать, чтобы выгодно обменять доллары на рубли.

+2
Ответы (1)
  1. 20 января, 14:32
    0
    Program Ulitka;

    Var SunnyDay: Array [1 ... 30] Of Boolean;

    a, b, c, i: Integer;

    Begin

    WriteLn ('a = ') ;

    ReadLn (a) ;

    WriteLn ('b = ') ;

    ReadLn (b) ;

    b : = b * 100;

    Randomize;

    For i : = 1 To 30 Do

    Begin

    If Random (2) = 1 Then

    SunnyDay[i] : = True

    Else

    SunnyDay[i] : = False;

    End;

    For i : = 1 To 30 Do

    Begin

    If SunnyDay[i] = True Then

    Begin

    a : = a + 2;

    If a > b Then

    a : = b;

    End

    Else

    Begin

    a : = a - 1;

    If a < 0 Then

    a : = 0;

    End;

    End;

    WriteLn ('Дни месяца были таковы:') ;

    For i : = 1 To 30 Do Begin

    If SunnyDay[i] = True Then

    WriteLn (i, '. Солнечный')

    Else

    WriteLn (i, '. Пасмурный')

    End;

    WriteLn ('К концу 30 дня местоположение улитки равно ', a, ' см над землей') ;

    ReadLn;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1 Каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см, а каждый пасмурный день опускается вниз на 1 см, В начале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
У вас есть доллары. Вы хотите обменять их на рубли. Есть информация стоимости купли-продажи в банках города. В городе 15 банков. Требуется определить, какой банк выбрать, чтобы наиболее выгодно обменять доллары на рубли. И вывести название банка
Ответы (2)
Язык программирования: Visual Basic Задача: У вас есть доллары. Вы хотите обменять их на рубли. Есть информация стоимости купли-продажи в банках города. В городе N банков.
Ответы (1)
Помогите подалуйста, программа нужна в массивах ... "У вас есть доллары. Вы хотите обменять их на рубли. Есть информация стоимости купли-продажи в банках города. В городе 15 банков.
Ответы (1)
Каждый солнечный день улитка сидящая на дереве поднимается вверх на 2 см а в пасмурный день опускается на 10 см. в начале недели улитка находилась на а см от земли и на в метровом дереве.
Ответы (1)
Каждый солнечный день улитка сидящая на дереве поднимается на 2 см а в каждый пасмурный день опускается на 1 см. в начале ноября улитка находилась ы А см от земли на В дереве. имеется 30 элем.
Ответы (1)