Задать вопрос
25 января, 19:53

Паскаль

Напишите программу, которая заполняет квадратную матрицу случайными числами в

интервале [10,99], и находит максимальный и минимальный элементы в матрице и их

индексы

+1
Ответы (1)
  1. 25 января, 20:48
    0
    Var a:array [1 ... 10, 1 ... 10] of integer;

    i, j, max, min, imin, imax, jmin, jmax:integer;

    begin

    imax:=0; imin:=0; jmax:=0; jmin:=0;

    max:=-maxint; min:=maxint;

    for i:=1 to 10 do

    begin

    for j:=1 to 10 do

    begin

    a[i, j]:=random (89) + 10;

    write (a[i, j],' ') ;

    if a[i, j]
    begin

    min:=a[i, j];

    imin:=i;

    jmin:=j;

    end;

    if a[i, j]>max then

    begin

    max:=a[i, j];

    imax:=i;

    jmax:=j;

    end;

    end;

    writeln;

    end;

    writeln;

    writeln ('Максимальный элемент:', max) ;

    writeln ('Его индекс ', imax,' ', jmax) ;

    writeln ('Минимальный элемент:', min) ;

    writeln ('Его индекс ', imin,' ', jmin) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль Напишите программу, которая заполняет квадратную матрицу случайными числами в интервале [10,99], и находит максимальный и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы