Задать вопрос
23 июня, 04:42

9 класс! Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - при знак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму чётных чисел.

+1
Ответы (1)
  1. 23 июня, 07:22
    0
    Var a, n, s:integer;

    begin

    n:=0; s:=0;

    readln (a) ;

    while a0 do

    begin

    n:=n+1;

    if a mod 2=0 then s:=s+a;

    readln (a) ;

    end;

    writeln ('n = ', n,' s = ', s) ;

    end.

    Пример:

    5

    2

    8

    7

    3

    0

    n = 5 s = 10
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «9 класс! Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. Программа получает на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы