Задать вопрос
10 декабря, 00:32

Дано натуральное число n определите количество цифр в цифровой записи его числа, которые имеют наибольшее значение пример N=1808, количество чифр с наибольшим значением равно 2 (две циры 8)

+3
Ответы (1)
  1. 10 декабря, 01:11
    0
    Var n, amount, max_digit, copy_of_n: integer;

    begin

    read (n) ;

    copy_of_n : = n;

    amount : = 0;

    max_digit : = copy_of_n mod 10;

    while copy_of_n 0 do

    begin {Находим наибольшую цифру в числе}

    if max_digit < copy_of_n mod 10

    then

    max_digit : = copy_of_n mod 10;

    copy_of_n : = copy_of_n div 10;

    end;

    copy_of_n : = n;

    while copy_of_n 0 do {Считаем количество таких цифр}

    begin

    if copy_of_n mod 10 = max_digit

    then

    amount : = amount + 1;

    copy_of_n : = copy_of_n div 10;

    end;

    writeln (amount) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число n определите количество цифр в цифровой записи его числа, которые имеют наибольшее значение пример N=1808, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы