Задать вопрос
30 сентября, 14:42

Помогите решить. Составьте программу формирования и вывода на экран одномерного массива, состоящего из элементов главной диагонали двумерного массива, заданного с помощью датчика случайных чисел. (Паскаль абс) С объяснением.

+4
Ответы (1)
  1. 30 сентября, 17:45
    0
    Const

    n=5

    var

    a:array[1 ... n] of integer; / / создали одномерный массив длинной 5

    b:array[1 ... n, 1 ... n] of integer; / / создали двумерный массив 5 х5

    i, j:integer; / / i, j - счетчик

    begin

    for i:=1 to n do

    for j:=1 to n do

    b[i, j]:=random (10) + 1; {задали массив случайными числами в диапазоне от 1 до 10}

    for i:=1 to n do

    begin

    a[i]:=b[i, i]; / / присваиваем i-ому элементу массива элемент i-i.

    end; / / То есть 1-ому, 1-1, 2-ому 2-2. Это и есть главная диагональ.

    {вывод двумерного массива на всякий случай:

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    write (b[i, j],' ') ;

    end;

    writeln ("") ;

    end; }

    For i:=1 to n do

    write (a[i]," ") ;

    readln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить. Составьте программу формирования и вывода на экран одномерного массива, состоящего из элементов главной диагонали ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы