Задать вопрос
26 сентября, 06:01

Помогите решить. Напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки. Выведите на экран исходный и измененный массив. (Паскаль абс) С объяснением

+5
Ответы (1)
  1. 26 сентября, 08:05
    0
    Const

    n=5;

    var

    a:array[1 ... n, 1 ... n] of integer;

    i, j:integer;

    begin

    //генератор случайных чисел. Диапазон от 1 до 10.

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (10) + 1;

    write (a[i, j]," ") ;

    end;

    writeln () ;

    end;

    //Проверка условия и переприсвоение, если верно.

    for i:=1 to n do

    for j:=1 to n do

    begin

    if (((i+j) mod 2) = 0) then

    a[i, j]:=a[1,2];

    end;

    //Вывод полученного массива.

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    write (a[i, j]," ") ;

    end;

    writeln () ;

    end;

    //Ожидание.

    readln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить. Напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел замените в нем значения элементов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы