Задать вопрос
23 апреля, 11:01

В паскале сформирвать массив из десяти элементов, заполнить его с помощью генератора случайных чисел и сделать так, чтобы в нем поменялись местами 1 и 2, 3 и 4 значение и так далее. Нужно написать программу.

+5
Ответы (1)
  1. 23 апреля, 11:24
    0
    Program Task;

    Var a: Array [1 ... 10] of Integer;

    i, tmp: Integer;

    Begin

    Randomize;

    WriteLn ('Сформированный массив:') ;

    For i : = 1 To 10 Do

    Begin

    a[i] : = Random (10) ;

    Write (a[i], ' ') ;

    End;

    WriteLn;

    For i : = 1 To 5 Do

    Begin

    tmp : = a[i * 2];

    a[i * 2] : = a[i * 2 - 1];

    a[i * 2 - 1] : = tmp;

    End;

    WriteLn ('Измененный массив:') ;

    For i : = 1 To 10 Do

    Write (a[i], ' ') ;

    ReadLn;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В паскале сформирвать массив из десяти элементов, заполнить его с помощью генератора случайных чисел и сделать так, чтобы в нем поменялись ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Задать массив из 10 элементов с пом. генератора случ. Чисел из интервала (10,30). Увеличить каждое число в массиве три раза. Вывести на экран оба массив (результат и исходный) 2. Дано 2 массива из 80 элементов.
Ответы (1)