Задать вопрос
6 сентября, 11:30

Написать программу, которая вводит целые числа и складывает их, пока не будет введено число 0. вывести сумму чисел, введённых до 0.

+1
Ответы (1)
  1. 6 сентября, 12:14
    0
    var

    sum, num: integer;

    begin

    repeat

    readln (num) ;

    if (num = 0) then

    break;

    write (sum, ' + ', num, ' = ') ;

    sum : = sum + num;

    writeln (sum) ;

    until (false) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая вводит целые числа и складывает их, пока не будет введено число 0. вывести сумму чисел, введённых до 0. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы