Задать вопрос
26 января, 05:29

Паскаль. Напишите программу, которая по последней цифре числа определяет последнюю цифру квадрата этого числа

+4
Ответы (2)
  1. 26 января, 06:56
    0
    Var i: Integer;

    begin

    write ('Число: ') ;

    readLn (i) ;

    i : = i mod 10;

    writeLn ('Цифра квадрата = ',

    sqr (i) mod 10) ;

    end.
  2. 26 января, 08:40
    0
    Var a, b: longint;

    begin

    write ('введите число - > ') ;

    readln (a) ;

    a:=a mod 10;

    b: = (a*a) mod 10;

    writeln ('последняя цифра квадрата числа - > ', b) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль. Напишите программу, которая по последней цифре числа определяет последнюю цифру квадрата этого числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы