Задать вопрос
16 мая, 19:20

Дано натуральное число n. Определить, во сколько раз произведение всех цифр заданного числа больше его первой цифры.

помогите написать программу в паскале.

+2
Ответы (1)
  1. 16 мая, 21:04
    0
    Var

    n, i, p, s: integer;

    begin

    p : = 1;

    s : = 0;

    read (n) ;

    while n > 0 do

    begin

    if (n div 10 < = 0) then s : = (n mod 10) ;

    p : = p * (n mod 10) ;

    n : = n div 10;

    end;

    if (s p) then write ('В ', p / s, ' раз')

    else write ('В ', 0, ' раз') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число n. Определить, во сколько раз произведение всех цифр заданного числа больше его первой цифры. помогите написать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы