Задать вопрос
28 ноября, 15:02

Найти сумму цифр в Паскале (используя while или repeat)

S=101+103 + ... + 301

Составить программу.

+4
Ответы (1)
  1. 28 ноября, 18:47
    0
    (использую repeat)

    var i, S:integer;

    begin

    S:=0; i:=101;

    repeat

    S:=S+i; i:=i+2;

    until i>301;

    Writeln (S) ;

    end.

    (использую While)

    var i, S:integer;

    begin

    S:=0; i:=101;

    while i<=301

    do begin

    S:=S+i; i; =i+2;

    end;

    Writeln (S) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти сумму цифр в Паскале (используя while или repeat) S=101+103 + ... + 301 Составить программу. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы