Задать вопрос
6 апреля, 05:50

составить программу на паскале

Дано натуральное число, найти сумму цифр этого числа!

+5
Ответы (1)
  1. 6 апреля, 09:15
    0
    Program Program1;

    var

    i, sum, n, code:integer;

    s:string;

    begin

    write ('Введите натуральноее число: ') ;

    readln (s) ;

    sum:=0;

    for i : = 1 to Length (s) do

    begin

    Val (s[i], n, code) ;

    sum:=sum + n;

    end;

    writeln ('Сумма цифр: ', sum)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составить программу на паскале Дано натуральное число, найти сумму цифр этого числа! ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы