Задать вопрос
11 апреля, 16:29

Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200.

Составить программу, которая вычисляет факториал числа 7!

+5
Ответы (1)
  1. 11 апреля, 18:35
    0
    Первая программа:

    var summ, k, i:Integer; sa:Real;

    begin

    summ:=0;

    k:=0;

    for i:=1 to 200 do

    begin

    if (i mod 3 = 0) then

    begin

    summ:=summ+i;

    k:=k+1;

    end;

    end;

    sa:=summ/k;

    WriteLn (sa) ;

    end.

    Вторая:

    var i, f:Integer;

    begin

    f:=1;

    for i:=1 to 7 do f:=f*i;

    WriteLn (f)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы