Задать вопрос
2 августа, 11:55

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N (1<=N<=10000000000), k (1<=k<=100)

Выходные данные: Программа выводит два таких числа, если они существуют,"NO" - если нет.

+1
Ответы (1)
  1. 2 августа, 12:30
    0
    Var k, j, sum:integer;

    n, i:longint;

    prev, cur, found : boolean;

    s:string;

    Begin

    read (n, k) ;

    for i : = 2 to n do begin

    s : = inttostr (i) ;

    sum : = 0;

    for j : = 1 to length (s) do

    sum : = sum + strtoint (s[j]) ;

    cur : = (sum mod k) = 0;

    found : = found or (prev and cur) ;

    if prev and cur then

    writeln (i - 1,' ', i) ;

    prev : = cur;

    end;

    if not found then writeln ('NO') ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы