Задать вопрос
12 апреля, 08:14

Дан целочисленный одномерный массив. Составьте программу, которая искала бы наибольший положительный элемент.

+4
Ответы (1)
  1. 12 апреля, 09:19
    0
    Program primer;

    const n=100;

    var a:array[1 ... n] of integer;

    i, max:integer;

    begin

    writeln ('vvedite massiv') ;

    for i:=1 to n do

    readln (' ', a[i]) ;

    max:=a[1];

    for i : = 1 to n do

    if (a[i]>a[1]) and (a[i]>0) then max:=a[i];

    writeln ('max=', max) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан целочисленный одномерный массив. Составьте программу, которая искала бы наибольший положительный элемент. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы