Задать вопрос
2 марта, 15:01

Написать в паскаль ABC

1) напишите программу, перемножающую целые числа без использования операции <>. например, при умножении целых чисел n*m число m надо сложить само с собой n раз (m+m + ... + m).

2) Напишите программу возведения числа в целую степень. Число и степень запрашивайте у пользователя.

+2
Ответы (2)
  1. 2 марта, 17:58
    0
    Uses crt;

    var x, y, pr, i:integer;

    begin

    pr:=0;

    write ('1 множитель:') ; readln (x) ;

    write ('2 множитель:') ; readln (y) ;

    for i:=1 to x do

    pr:=pr+y;

    writeln ('произведение:', pr) ;

    end.

    ---

    uses crt;

    var x, y, st, i:integer;

    begin

    st:=1;

    write ('число:') ; readln (y) ;

    write ('степень:') ; readln (x) ;

    for i:=1 to x do

    st:=st*y;

    writeln ('результат::', st) ;

    end.
  2. 2 марта, 18:29
    0
    Опишу только момент, в котором вся суть, т. е. без ввода данных и т. д.:

    ...

    for i:=1 to (на сколько надо умножить) do

    k:=k+a {k-итоговая сумма, перед циклом к=0, в конце к0; a-вводимое число}

    ...

    таким же образом поступаем и с умножением
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать в паскаль ABC 1) напишите программу, перемножающую целые числа без использования операции . например, при умножении целых чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы