Задать вопрос
19 июля, 10:56

В паскале!

Известно,

что Покупатель приобрел а кг яблок по цене в руб. и с кг груш по цене d руб.

Покупатель имеет S рублей. Напишите программу, которая определяет, хватит ли у

покупателя средств на данную покупку?

+4
Ответы (2)
  1. 19 июля, 11:05
    0
    Program one;

    var s, a, b, c, d, m:real;

    begin

    writeln ('Введите цену яблок, груш ') ;

    readln (s, a) ;

    writeln ('Введите кол-во яблок, груш в кг ') ;

    readln (b, c) ;

    m: = (a*b) + (c*d) ;

    if s > = m then writeln ('Денег хватит', m)

    else

    writeln ('Денег не хватит') ;

    end.
  2. 19 июля, 13:38
    0
    Program cena;

    uses crt;

    var

    s, a, b, c, d, su:real;

    begin

    clrscr;

    writeln ('Cymma kotopaya ectb y pokypatelya: ') ;

    read (s) ;

    writeln ('Ckolko priobel yablock (kg) : ') ;

    read (a) ;

    writeln ('Cena yablock:') ;

    read (b) ;

    writeln ('Ckolko priobrel grush (kg) : ') ;

    read (c) ;

    writeln ('Cena grush: ') ;

    read (d) ;

    su: = (a*b) + (c*d) ;

    if s > = su then writeln ('dannoy summu hvatit dlya etoy pokypki, vsego za pokupku ', su)

    else

    writeln ('Etoy symmu ne hvatit dlya pokupki') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В паскале! Известно, что Покупатель приобрел а кг яблок по цене в руб. и с кг груш по цене d руб. Покупатель имеет S рублей. Напишите ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы